Author Topic: sharpkeys  (Read 1503 times)

0 Members and 1 Guest are viewing this topic.

Offline sinis

  • Thread Starter
  • Posts: 470
sharpkeys
« on: Mon, 21 November 2011, 04:18:28 »
Hi,

I am facing a problem with remapping some keys in Windows 7 64 bit. Using the software sharpkeys, I turned the key 00_29 off. On US ANSI it should be the ~ key.

The Problem:
Under Windows and in most Windows Applications, such as Wordpad and Firefox, the key has now correctly turned off. However, when I play Battlefield3, the key opens the console like it has never been turned off. I play Battlefield3 in english. And the keyboard is qwerty in BF3. Sharpkeys is in English, too. It recognizes the key I want to turn off as ~` .

The next symptom I recognize is, I can open the console with ~ in BF3, though the key is turned off in the registry. But closing the console is not possible by pressing is again. This works only when the key is turned on.

I did restart the PC after remapping / turning off the key to make the changes in the registry applicated in windows.

I do not understand, what I do wrong right now.
Anyone can help me?

Regards
sinis
« Last Edit: Mon, 21 November 2011, 04:28:29 by sinis »

Offline sinis

  • Thread Starter
  • Posts: 470
sharpkeys
« Reply #1 on: Mon, 21 November 2011, 13:34:02 »
I tried it with an .exe, but it does not work either. The key is not getting properly blocked.

Is the raw code of the key different in ANSI and ISO?

Offline pyro

  • Posts: 184
sharpkeys
« Reply #2 on: Mon, 21 November 2011, 15:01:29 »
Some applications don't care about your keyboard mapping. That's why I don't have to revert to QWERTY to play Skyrim.

Offline AUAnonymous

  • Posts: 52
sharpkeys
« Reply #3 on: Tue, 22 November 2011, 01:48:51 »
I believe some applications, especially games like BF3 or Skyrim as pyro mentioned, read keyboard input at a lower level than whatever level the windows registry is at, or at least lower than the level at which it implements the mappings. This means that likely the only practical thing (on windows at least) that can can change what these games see is an actual difference in hardware.
Noppoo Choc Mini (MX Blacks) - First mechanical keyboard :D
Why don\'t you give Colemak a try? You\'ll like it, I promise.*

*Not a real promise

Offline sinis

  • Thread Starter
  • Posts: 470
sharpkeys
« Reply #4 on: Tue, 22 November 2011, 03:29:02 »
this would explain why the key is not turned off, but there is one more phenomenon:

the key is working one time. then it is blocked. the problem: if you press it one time, the console opens and blocks every single action you want to do. Exiting the game only possible via Alt+F4 and similar.

Changing the standard keyboard layout to UK ISO brings the same result:

- the key is correctly disabled in Windoze
- In Battlefield3 it opens the console
and the console can now not be shut. The game must be closed via Alt+F4

I assume it is an issue with BF3. Or it is an issue with the key having so much functions. As it only works one time to open the console and then it does not work anymore it could be the function like writing accents like , , and so on.

Maybe asking the BF3 support helps.

Offline peda

  • Posts: 344
sharpkeys
« Reply #5 on: Tue, 22 November 2011, 05:07:17 »
I don't think it is the problem of bf3 or win7.

I think sharpkeys has a problem with working in some games. As reported here as well: sharpkeys.codeplex.com/workitem/8044

But as it got reported in february and the issue is still unassigned and low priority, I don't see a solution from the developer any time soon.

What you actually can hope for is that dice makes the key rebindable with the next patch (next week hopefully)

Offline sinis

  • Thread Starter
  • Posts: 470
sharpkeys
« Reply #6 on: Tue, 22 November 2011, 05:26:50 »
maybe autohotkey works ...