geekhack Marketplace > TMK Keyboard Service

[TMK] USB-USB Converter

<< < (2/7) > >>


--- Quote ---it doesn't seem to work.

--- End quote ---
Describe more details. Any key doesn't register? What do you expect?

Try this keyboard test program to see what key registers.

Try official default firmware first to check if your converter itself works. You can download here.

Check the first post also, especially Troubleshoot section.

If you got error in the tool while flashing. Post the error.

Hi, thanks for answering!
The issue is that when I type with the external keyboard through the converter, it doesn't type anything in notepad. It should be able to type things normally. The hex code is supposed to make it so that F24 is held down before the regular key is pressed and then lifted once it's done. This is so that the keyboard can be detected as a different keyboard by autohotkey. It should send regular key presses without any script running though. I don't see any errors in qmk but here's a screenshot just in case. I'm using the Keychron K2 and Drevo Excalibur keyboards by the way.
Now I tried using the default hex file you provided and that seemed to flash correctly. It gave me blue text I had not seen with the hex that I was using at first. Using the default hex file you provided, qmk toolbox detected my key presses and displayed numbers each time. The Switch Hitter program only ever detected key presses from my laptop keyboard though. Nothing on the switch hitter changed when I pressed keys on the external keyboard (through hasu) but I did see the numbers in qmk toolbox.
So is it looking like the issue with the hex file I was using?
Sending a screenshot after "flashing" the hex file from the video, and another after flashing the one you provided.
Thanks again for the help!

Use the default firmware when testing.

It seems to work with the default firmware at least.
If you are using AHK and any other keyboard tools try disabling them or uninstalling.

EDIT: also try other keyboard, this problem may be caused by keyboard compatibility.
EDIT: and trying on other computer may be helpful.

Is the default firmware supposed to send keystrokes like normally? Because it doesn't send anything to notepad or switch hitter. Only to qmk toolbox. or is that normal? I disabled the other scripts and tried other computers/keyboards. Is the issue looking like it's the hex file not being correct? The way I understand it is that if the hex file were working, it'd say "hid console connected" right?

- Yes, the default firmware sends keystroke basically as you press.
- No, it is not normal. You can type in notepad with default firmware if there is no problem.

The default firmware is working when you see "TMK:ed7dfa/LUFA:d6a7df/UHS2:e37ed6" on hid_listen console. I believe you flashed the default firmware correctly.

QMK toolbox is not reliable completely in terms of debug console, use hid_listen instead to get debug outputs.

If you happen to have one of 'Compatible Keyboards' try it. It should work. Check first post for 'Compatible Keyboards'.


[0] Message Index

[#] Next page

[*] Previous page

Go to full version