Red Scarf III User’s Guide
How to Reflash

Rev1.0 by kai1103

Red Scarf Il is shipped with a special bootloader which is based on the LUFA’s BootloaderPrinter.
So user cannot use tkg-toolkit (formerly dfu-reflash) to reflash firmware to Red Scarf Ill as usual.
Instead the new bootloader is more interesting and easier to use.
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1. Reflash Mode

Red Scarf lll’'s bootloader has 2 reflash modes. Please take care to choose the appropriate mode
according to usage. Reflash file into incorrect mode will cause keyboard to stop working (not be
bricked, can be restored by reflashing correct file again).

Table 1: Reflash Mode

Mode Application How to Enter Indicator
Reflash | Update configurations @ Hold the key at top-left corner Blink LED of Caps Lock
EEP (e.g. keymap) (commonly Esc) and plug usb cable
Reflash | Update features Hold the two keys at top-left corner | Blink LEDs of Caps Lock
HEX (commonly Esc and F1) and plug usb | and Num Lock

cable

When the keyboard is running in reflash mode, a new device called “LUFA Printer Bootloader” will
be found. Commonly it’s no need to install a customized driver. Please wait until OS find a proper
driver automatically.
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__ Driver Software Installation @
Installing device driver software

LUFA Printer Bootloader L_#5earching preconfigured driver folders..,

Figure 1: Screenshot of installing device driver

. Driver Software Installation @
Your device is ready to use

USE Printing Support + Ready to use
Generic / Text Only + Ready to use

Figure 2: Screenshot of device driver installation successful



If the device driver has been installed successfully, you can find a new printer called “Generic /
Text Only” in the “Device and Printers”. If there is any trouble when installing driver, please refer
to “FAQ”".
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Figure 3: Screenshot of “Devices and Printers”

2. Make Keymap
To reflash a keymap, first you should make your keymap. This is similar to other keyboards which
using TKG solution. Please refer to some documents of TMK and TKG for more details.

2.1.Template

Here are some templates of several common keymap for simple mode:

e 104WK: http://www.keyboard-layout-
editor.com/layouts/1d60edf38aaee02d8067163e7c253bb8
e 1800+WIN: http://www.keyboard-layout-
editor.com/#/layouts/edb1b9a187ce9ed917fb96a7achfee98
e 1800: http://www.keyboard-layout-
editor.com/#/layouts/lae3adlcc3fa9lefcb0279025f8ec42d
e WKL101: http://www.keyboard-layout-
editor.com/#/layouts/b6aba0a2dcb19c5ddde615e45d4b9alb

Below is a sample of Fn code which can be imported into TKG by using “Menu>Tools>Import Fn”.
This is also the default Fn settings shipped with the keyboard.


http://www.keyboard-layout-editor.com/layouts/1d60edf38aaee02d8067163e7c253bb8
http://www.keyboard-layout-editor.com/layouts/1d60edf38aaee02d8067163e7c253bb8
http://www.keyboard-layout-editor.com/%23/layouts/edb1b9a187ce9ed917fb96a7acbfee98
http://www.keyboard-layout-editor.com/%23/layouts/edb1b9a187ce9ed917fb96a7acbfee98
http://www.keyboard-layout-editor.com/%23/layouts/1ae3ad1cc3fa91efcb0279025f8ec42d
http://www.keyboard-layout-editor.com/%23/layouts/1ae3ad1cc3fa91efcb0279025f8ec42d
http://www.keyboard-layout-editor.com/%23/layouts/b6a6a0a2dcb19c5ddde615e45d4b9a1b
http://www.keyboard-layout-editor.com/%23/layouts/b6a6a0a2dcb19c5ddde615e45d4b9a1b

"@":["ACTION_LAYER_MOMENTARY",1],"1":["ACTION_BACKLIGHT TOGGLE"],"2":["AC
TION BACKLIGHT DECREASE"],"3":["ACTION BACKLIGHT INCREASE"],"4":["ACTION_
FUNCTION","2",0],"5": ["ACTION_FUNCTION","7",0],"6":["ACTION_FUNCTION","7"
,"1"1,"7":["ACTION_FUNCTION","4",0],"8":["ACTION_FUNCTION","3",0],"9":["A
CTION_FUNCTION","6","2"],"1@":["ACTION_FUNCTION","5","1"],"11":["ACTION_F
UNCTION","5","4"],"12":["ACTION_FUNCTION","5","13"],"13":["ACTION_FUNCTIO
N","5","5"],"14": ["ACTION_FUNCTION","5","11"],"15":["ACTION_FUNCTION","5"
,"6"1,"16" : ["ACTION_FUNCTION","5","15"],"17":["ACTION_FUNCTION","5",0]

2.2.Built-in Function
The RGB LEDs on the bottom of Red Scarf 1l are controlled by both remoter and Fn built-in

function.

Table 2: Button number of remoter

Figure 4: A photo of remoter



Table 3: Table of Fn built-in functions

Remoter | Description
RGB Off - 4 | TurnlLEDsoff

'RGBToggle - NA*
R

Fn Built-in Function

Increase brightness (for fixed color) or speed

RGB Increase (for variable mode)

Green |6
|
Red1l o

Greenl 10
Red2 13
Blue2 15

|
|
|

RGB Fixed Color Change LEDs to fixed color

RGB Variable Mode Change LEDs to variable mode
: -
RGB Step Step through all fixed colors

* These features are designed for saving Fn keys, no corresponding on remoter.
** Keyboard can memory LED status changed by Fn but not status changed by remoter.

3. Online Reflash

We provide a convenience “Online Reflash” feature for Red Scarf lll. This feature requires user
have installed Java for their browser. If you hate Java or are just in a rush, please skip this chapter
and see “Offline Reflash”.



3.1.Enable Plugin

1. We recommend that you use the latest version of modern browsers, like Google Chrome
or Mozilla Firefox. Some features won’t work with old version of Internet Explorer.

2. |Install Java for browser and update it to the latest version.

3. Open “Configure Java” from start menu. Switch to “Security” tab and click “Edit Site List...”
button.

i

| £ Java Control Panel E (=] @
| General I Update | Ja'ua| Security | Advanced

Enable Java contentin the browser

Security level for applications not on the Exception Site list

71 Very High - Only Java applications identified by a certificate from a trusted authority are
allowed to run, and only if the certificate can be verified as not revoked.

@ High - Java applications identified by a certificate from a trusted autharity are allowed to
run, even if the revocation status of the certificate cannot be verified.

Exception Site List
Applications launched from the sites listed below will be allowed to run after the appropriate security

prompts.
IClick Edit Site List..
[0 @dd 1tems 1o s Ist, | Edlt §|te List... |
Restore Security Prompts ] [ Manage Certificates... ]
Ok ] [ Cancel Apply

Figure 5: Screenshot of Security tab of Java Control Panel

4. Add “http://www.enjoyclick.org/tkg/” to Exception Site List, and then click “OK”.



o

|| Exceptien Site List ==

-

Applications launched from the sites listed below will be allowed to run after the appropriate security prompts,

Location

mtu:u:,.’,.'In'ww.enjnydid:.nrg,.’ﬁigﬂ

[ Add ] [ Eemaove ]
'{H FILE and HTTF protocols are considered a security risk. We recommend using HTTPS sites where available.

[ oK ] [ Cancel ]

Figure 6: Screenshot of editing Exception Site List

5. Open “http://www.enjoyclick.org/tkg/” in browser. Choose keyboard to “RedScarflll”, and
then enable plugin on this page.
For example if you are using Google Chrome, there will be a blocked plugin icon at the
right side of address bar. Select “Always allow plug-ins on www.enjoyclick.org” and click
“Done”.

X

o

L]

1 : The following plug-ins were blocked on this page: Learn more

Javal(Th)

(®) Always allow plug-ins on www.enjoyclick.org:

Continue blocking plug-ins

Run all plug-ins this time

Manage plug-in blocking... Done

Figure 7: Screenshot of blocked plugin popup of Google Chrome



6. Then the following dialog will be shown. Check “l accept the risk and want to run this
application”, and then click “Run”.

Security Warning @

Do you want to run this application?

-

Name: QZ Print Plugin

/ ' ": Publisher: UNKNOWN

Location: http:/fwww.enjovdick.org

Running this application may be a security risk

Risk: This application will run with unrestricted access which may put your computer and personal
information at risk, The information provided is unreliable or unknown so it is recommended not to
run this application unless you are familiar with its source

More Information

Select the box below, then click Run to start the application

1 accept the risk and want to run this application.; Run ] l Cancel

Figure 8: Screenshot of Security Warning of Java

7. |If all these operations success. The icon of “Burn .eep file” will change from gay/white
block to a fire icon.

3.2.Reflash EEP

1. Configure your keymap properly on TKG.

Turn keyboard into “Reflash EEP” mode. (Please refer to “Reflash Mode” for details)
Click “Burn .eep file” on TKG.

LED of Caps Lock will flash rapidly, and soon turn on. Simultaneously, the print job will

B wNnN

disappear from the “What’s printing” dialog.



= Generic / Text Only EIIEI

Brinter Document  View

Docurment Mame Status Owner Pages Size Sut

QZ-PRIMT Raw Printing Printing Kai-Win7 1 282 KB/282KE T

4

L) I

1 document(s) in queue

5.

Figure 9: Screenshot of what’s printing dialog

Re-plug the usb cable. The keyboard will work with the new keymap now.

3.3.Reflash HEX
Please note that Red Scarf Il is shipped with the latest firmware, so ordinary it’s no need to reflash

HEX.

Make sure your keyboard is running in “Reflash HEX” mode. (Please refer to “Reflash
Mode” for details)

Open “http://www.enjoyclick.org/tkg/” in browser, choose keyboard to “RedScarflll”.
Hold down shift key, then the label of “Burn .eep file” button will change to “Burn .hex
file”.

Click “Burn .hex file” button.

LEDs of Caps Lock and Num Lock will flash rapidly, and soon turn on. Simultaneously, the
print job will disappear from the “What’s printing” dialog.

Re-plug the usb cable. The keyboard will work with the new keymap now.

4. Offline Reflash

If you have problem with “Online Reflash” feature, don’t worry. We also provide a “Offline Reflash”

feature too.

4.1.Reflash EEP

1.

2.
3.
4

Configure your keymap properly on TKG and click “Download .eep file”.
Turn keyboard into “Reflash EEP” mode. (Please refer to “Reflash Mode” for details)
Open the downloaded .eep file with Notepad, and click “Menu>File>Print”.

Select “Generic / Text Only” printer and click “Print”.



o o)

= Print @

General
Select Printer
%‘lﬂu:ld Printer = Microsoft XPS Docurmen
= Fax
= Generic / Text Cnly
1 1 p
Status: Ready [ Prirt to file
Location:
Commert:
Page Range
@ Al Mumber of copies; 1 =
Selection Curent Page
Fages: Caollate
111 2)2!| 3)3

Prirt ] [ Cancel Apply

5. LED of Caps Lock will flash rapidly, and soon turn on. Simultaneously, the print job will
disappear from the “What'’s printing” dialog.
6. Re-plug the usb cable. The keyboard will work with the new keymap now.

4.2.Reflash HEX

Please note that Red Scarf Il is shipped with the latest firmware, so ordinary it’s no need to reflash
HEX.

1. Make sure your keyboard is running in “Reflash HEX” mode. (Please refer to “Reflash
Mode” for details)

2. Open .hex file with Notepad, and click “Menu>File>Print”.

3. Select “Generic / Text Only” printer and click “Print”.
LEDs of Caps Lock and Num Lock will flash rapidly, and soon turn on. Simultaneously, the
print job will disappear from the “What’s printing” dialog.

5. Re-plug the usb cable. The keyboard will work with the new keymap now.

10



5. FAQ

1.

If you failed on installing device driver of bootloader, please confirm if the “Print Spooler”
is stopped. If stopped, please start it and try again.

Changing Red Scarf Il to another usb port and turn it into bootloader mode will cause OS
recognize it as a duplicated printer. Remove all printers and re-add one can make “Online
Reflash” working again.

If you failed on “Offline Reflash” repeatedly, please try to open “Printer properties” and
uncheck “Enable advanced printing features”.

See what's printing

Set as default printer

Printing preferences

Printer properties
Create shortcut

Troubleshoot

aneric / Tex Remove device

Properties

= x

Figure 10: Screenshot of context menu of printer
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=) Generic / Text Only Properties

Securty I Device Settings I Prirter Commands | Fort Selection

General | Sharing I Ports | Advanced | Color Management

@ Always available

(0) Available from 12:00 AM = Ta 12:00 AM
Pricrity: 1 =
Drriver: Generic / Text Only v] ’ Mew Driver...

i@ Spool print documents =o program finishes printing faster
() Start printing after last page is spooled
(@ Start printing immediately

() Print directly to the printer

[]Held mismatched documents
Print spocled documents first
[T Keep printed documents

[|Enable advanced printing features

’ Printing Defaults... ]’ Print Processor... l’ Separator Page...

| ok || Cancel Apply

Figure 11: Screenshot of Advanced tab of printer properties
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