Author Topic: Bug Reports  (Read 271324 times)

0 Members and 2 Guests are viewing this topic.

Offline mkawa

  •  No Marketplace Access
  • Thread Starter
  • Posts: 6562
  • (ツ)@@@. crankypants
Bug Reports
« on: Fri, 20 July 2012, 23:29:55 »
Something broken? Post below and we'll ignore it get to work!

to all the brilliant friends who have left us, and all the students who climb on their shoulders.

Offline mkawa

  •  No Marketplace Access
  • Thread Starter
  • Posts: 6562
  • (ツ)@@@. crankypants
Re: Bug Reports
« Reply #1 on: Fri, 20 July 2012, 23:38:53 »
speaking of bugs, we were having an issue yesterday and earlier today where password reset emails were being dropped by outbound forwarders. that should be resolved now. please report if you're still not getting your activation or password reset emails.

to all the brilliant friends who have left us, and all the students who climb on their shoulders.

Offline bpiphany

  • Posts: 1012
  • Location: Stockholm, Sweden
  • bpiph is a special type of crazy. //mkawa
Re: Bug Reports
« Reply #2 on: Sat, 21 July 2012, 02:41:04 »
The email finally worked for me, apparently =)

When I click someones nick (like your's in this view) I get sent to an

"An Error Has Occurred!
You are not allowed to access this section"

-page.

Offline The_Ed

  • Posts: 1350
  • Location: MN - USA
  • Asperger's... SQUIRREL! I'm Anal Retentive *****!
Re: Bug Reports
« Reply #3 on: Sat, 21 July 2012, 03:28:15 »
How do I change my "Custom Title"? There doesn't seem to be an option. I want to get rid of the "\" that somehow got injected. I seem to remember using \' to print ' in one of my coding classes, but don't remember which language. So it seems like something that would easily be overlooked in the import.

My signature got borked as well. When I try to recreate it I run into a 500 character limit. The formatting tags take up a lot of characters so WTF.

And why do swear words get replaced with "puppies"? I like asterisks more than that. Or how about no swear filter at all? Please?
Reaper "frelled" me... Twice... Did he "frell" you too?... *brohug*
I'm camping for a week, and moving twice in a month. I'll get back to you when I can (If I don't then just send me another PM).
R.I.P.ster

Offline tobr1an

  • Posts: 137
Re: Bug Reports
« Reply #4 on: Sat, 21 July 2012, 03:30:01 »
I believe geekhack is flagged as dangerous site by mcafee

Offline metafour

  • Posts: 667
  • Location: Los Angeles
Re: Bug Reports
« Reply #5 on: Sat, 21 July 2012, 12:15:27 »
Please remove the popup about Tapatalk from appearing when visiting the site while not logged in on an iPad. The iPad should be treated as a desktop browser and the Tapatalk alert doesn't popup on the desktop.

fartq

  •  Guest
Re: Bug Reports
« Reply #6 on: Sat, 21 July 2012, 12:17:24 »
Please remove the popup about Tapatalk from appearing when visiting the site while not logged in on an iPad. The iPad should be treated as a desktop browser and the Tapatalk alert doesn't popup on the desktop.
that may actually be coming from a library loaded off the tapatalk servers, and non-removable. will see what we can do though

Offline Soarer

  • * Elevated Elder
  • Posts: 1918
  • Location: UK
Re: Bug Reports
« Reply #7 on: Sat, 21 July 2012, 16:14:01 »
30-second limit between searches is fine, but does it really have to restart the count every damn time it refuses?!!!

Offline mkawa

  •  No Marketplace Access
  • Thread Starter
  • Posts: 6562
  • (ツ)@@@. crankypants
Re: Bug Reports
« Reply #8 on: Sun, 22 July 2012, 02:26:51 »
that's a straight up bug in SMF. i'll file it with the SMF folks.

to all the brilliant friends who have left us, and all the students who climb on their shoulders.

Offline metafour

  • Posts: 667
  • Location: Los Angeles
Re: Bug Reports
« Reply #9 on: Sun, 22 July 2012, 09:54:27 »
Please remove the popup about Tapatalk from appearing when visiting the site while not logged in on an iPad. The iPad should be treated as a desktop browser and the Tapatalk alert doesn't popup on the desktop.
that may actually be coming from a library loaded off the tapatalk servers, and non-removable. will see what we can do though

Pure marketing tactic. Those savages!

Offline Thepope

  • Posts: 9
Re: Bug Reports
« Reply #10 on: Tue, 24 July 2012, 07:32:33 »
I tried searching Ducky Shine 2 and got this error:



Each word must be at least two characters long.

Offline Thepope

  • Posts: 9
Re: Bug Reports
« Reply #11 on: Tue, 24 July 2012, 07:36:32 »
In fact is search working?

I tried "Ducky Shine" and latest post is April 2012.

Offline Soarer

  • * Elevated Elder
  • Posts: 1918
  • Location: UK
Re: Bug Reports
« Reply #12 on: Tue, 24 July 2012, 07:51:49 »
Search is working, but by default it shows results in order of 'relevance'. You could try advanced search instead, which lets you change to showing most recent hits first.

I think date order probably makes most sense for GH...

Offline alaricljs

  • I be WOT'ing all day...
  • ** Moderator Emeritus
  • Posts: 3715
  • Location: NE US
Re: Bug Reports
« Reply #13 on: Tue, 24 July 2012, 08:42:39 »
Also there will be references to Ducky Shining that your particular search will miss.
Filco w/ Imsto thick PBT
Ducky 1087XM PCB+Plate, w/ Matias "Quiet Click" spring-swapped w/ XM Greens

Offline Djuzuh

  • Posts: 1127
Re: Bug Reports
« Reply #14 on: Thu, 26 July 2012, 16:52:55 »
Every refresh now and then Moderate gets in the link bar at top (between search and profile).

Obviously clicking on it gets me an error as I don't have any moderation power.

But still, why do I see it sometimes.

And it seems like it's totally random. I refresh the same page 4 time in a row without the moderation link, and the fifth time it is on the page.

fartq

  •  Guest
Re: Bug Reports
« Reply #15 on: Sat, 28 July 2012, 08:31:48 »
i have absolutely no clue, and i can't repro. if you can figure out how to reproduce it reliably let me know

Offline mkawa

  •  No Marketplace Access
  • Thread Starter
  • Posts: 6562
  • (ツ)@@@. crankypants
Re: Bug Reports
« Reply #16 on: Sat, 28 July 2012, 08:53:33 »
i've adjusted search weighting slightly

to all the brilliant friends who have left us, and all the students who climb on their shoulders.

Offline mkawa

  •  No Marketplace Access
  • Thread Starter
  • Posts: 6562
  • (ツ)@@@. crankypants
Re: Bug Reports
« Reply #17 on: Sat, 28 July 2012, 08:55:59 »
Please remove the popup about Tapatalk from appearing when visiting the site while not logged in on an iPad. The iPad should be treated as a desktop browser and the Tapatalk alert doesn't popup on the desktop.
fixed

to all the brilliant friends who have left us, and all the students who climb on their shoulders.

Offline Soarer

  • * Elevated Elder
  • Posts: 1918
  • Location: UK
Re: Bug Reports
« Reply #18 on: Sat, 28 July 2012, 09:26:44 »
i've adjusted search weighting slightly

Hmm. I just tried it out and I'm not sure it's the right way to go - I think it reduces the difference between 'most relevant' and 'most recent' searches too much.

I'm not really sure which kind of search the majority of users would expect to get from a quick search. My guess would be that most quick searches are for recent posts, but that's just a hunch.

fartq

  •  Guest
Re: Bug Reports
« Reply #19 on: Sun, 29 July 2012, 09:40:28 »
this may be something that time will work out. once more people start hitting the search engine heavily we may get a better idea of how to weight the quick search

Offline rknize

  • * Administrator
  • Posts: 1717
  • Location: Chicago
    • metaruss
Re: Bug Reports
« Reply #20 on: Mon, 06 August 2012, 17:06:35 »
:/1429-0
Russ

fartq

  •  Guest
Re: Bug Reports
« Reply #21 on: Mon, 06 August 2012, 17:23:53 »
those arrow keys still work russ?

Offline biochem

  • Posts: 116
  • Location: New England
Re: Bug Reports
« Reply #22 on: Mon, 06 August 2012, 18:48:21 »
The password reset isn't working for me, i.e. I'm not getting an email.

I did reset my password after the GeekHack reboot, but I can't remember my new password. I can only log in from one computer where FireFox remembers it for me.

Thanks in advance.
Filco MJ2 tenkeyless (blues)
Heatware

Offline alaricljs

  • I be WOT'ing all day...
  • ** Moderator Emeritus
  • Posts: 3715
  • Location: NE US
Re: Bug Reports
« Reply #23 on: Mon, 06 August 2012, 19:22:09 »
Just as a note re: firefox passwords, you can find out what is saved as your password quite easily through the Options dialog.
Filco w/ Imsto thick PBT
Ducky 1087XM PCB+Plate, w/ Matias "Quiet Click" spring-swapped w/ XM Greens

Offline biochem

  • Posts: 116
  • Location: New England
Re: Bug Reports
« Reply #24 on: Wed, 08 August 2012, 20:26:04 »
Just as a note re: firefox passwords, you can find out what is saved as your password quite easily through the Options dialog.

Thanks for that tip. You solved my problem.
Filco MJ2 tenkeyless (blues)
Heatware

Offline rknize

  • * Administrator
  • Posts: 1717
  • Location: Chicago
    • metaruss
Re: Bug Reports
« Reply #25 on: Thu, 09 August 2012, 22:06:16 »
1802-0
Russ

Offline boost

  • BOSTMOBILE
  • * Elevated Elder
  • Posts: 3285
  • NY Giants!!!
Re: Bug Reports
« Reply #26 on: Thu, 09 August 2012, 22:38:30 »
had tapatalk issues not too long ago(1hr or so)
"Aerodynamics are for people who can't build engines."

-Enzo Ferrari

Offline sth

  • 2 girls 1 cuprubber
  • Posts: 3400
  • ftdoc.nl
    • forthedeclineofcivilisation
Re: Bug Reports
« Reply #27 on: Thu, 09 August 2012, 22:42:15 »
(Attachment Link)
if i had that model F, i'd have every keyboard on that desk :) Not counting the macbook - i have the older non-chiclet version.

boost- whole site was down about that long ago so probably not a tapatalk issue
11:48 -!- SmallFry [~SmallFry@unaffiliated/smallfry] has quit [Ping timeout: 245 seconds] ... rest in peace

Offline boost

  • BOSTMOBILE
  • * Elevated Elder
  • Posts: 3285
  • NY Giants!!!
Re: Bug Reports
« Reply #28 on: Thu, 09 August 2012, 22:43:29 »
(Attachment Link)
boost- whole site was down about that long ago so probably not a tapatalk issue


lol, I didn't know that, thanks for the info sth!!!
"Aerodynamics are for people who can't build engines."

-Enzo Ferrari

Offline rknize

  • * Administrator
  • Posts: 1717
  • Location: Chicago
    • metaruss
Re: Bug Reports
« Reply #29 on: Thu, 09 August 2012, 22:58:09 »
if i had that model F, i'd have every keyboard on that desk :) Not counting the macbook - i have the older non-chiclet version.

:)  I was just reverifying attachments.

boost- whole site was down about that long ago so probably not a tapatalk issue

We had a slight problem earlier, but we're back now.

http://geekhack.org/index.php?topic=33535.msg637201#msg637201
Russ

Offline rknize

  • * Administrator
  • Posts: 1717
  • Location: Chicago
    • metaruss
Re: Bug Reports
« Reply #30 on: Thu, 09 August 2012, 22:58:36 »
if i had that model F, i'd have every keyboard on that desk :) Not counting the macbook - i have the older non-chiclet version.

:)  i was just double-checking attachments.

boost- whole site was down about that long ago so probably not a tapatalk issue

We had a slight problem earlier, but we're back now.

http://geekhack.org/index.php?topic=33535.msg637201#msg637201
Russ

Offline rknize

  • * Administrator
  • Posts: 1717
  • Location: Chicago
    • metaruss
Re: Bug Reports
« Reply #31 on: Fri, 10 August 2012, 00:15:22 »
Russ

Offline sth

  • 2 girls 1 cuprubber
  • Posts: 3400
  • ftdoc.nl
    • forthedeclineofcivilisation
Re: Bug Reports
« Reply #32 on: Fri, 10 August 2012, 00:16:31 »
nice! this should make the music thread a little better.

almost didn't notice the embed since my flashblock makes video frames appear near-black.
« Last Edit: Fri, 10 August 2012, 00:20:31 by sth »
11:48 -!- SmallFry [~SmallFry@unaffiliated/smallfry] has quit [Ping timeout: 245 seconds] ... rest in peace

Offline rknize

  • * Administrator
  • Posts: 1717
  • Location: Chicago
    • metaruss
Re: Bug Reports
« Reply #33 on: Fri, 10 August 2012, 00:19:43 »
Mkawa put it in some time back, it's just that there is no button for it in the GUI.  Just use the
Code: [Select]
[youtube]URL[/youtube] tag.

We are working on replacing these different media solutions that we have now with a better one.
« Last Edit: Fri, 10 August 2012, 00:21:14 by rknize »
Russ

Offline rknize

  • * Administrator
  • Posts: 1717
  • Location: Chicago
    • metaruss
Re: Bug Reports
« Reply #34 on: Fri, 10 August 2012, 16:51:38 »
(Attachment Link)

Did it work?

Edit: yup...attachment links fixed.
Russ

Offline damorgue

  • Posts: 1176
  • Location: Sweden
    • Personal portfolio
Re: Bug Reports
« Reply #35 on: Fri, 10 August 2012, 17:27:17 »
Someone keeps messing with my head.

Offline mkawa

  •  No Marketplace Access
  • Thread Starter
  • Posts: 6562
  • (ツ)@@@. crankypants
Re: Bug Reports
« Reply #36 on: Fri, 10 August 2012, 17:36:28 »
oops

to all the brilliant friends who have left us, and all the students who climb on their shoulders.

Offline emptyk

  • Posts: 106
Re: Bug Reports
« Reply #37 on: Sat, 11 August 2012, 09:26:29 »
Notifications are not working for me. Is this a sitewide issue or are my settings wrong? I have subscribed to some threads with daily notifications, but have never received any email, PM, etc.

Offline cactux

  • Posts: 918
  • Location: Australia
  • Topre Knight
Re: Bug Reports
« Reply #38 on: Sat, 11 August 2012, 09:29:22 »
have you consider using a more formal way to track the bugs like bugzilla?
[FS]☠ The temple lol ->HERE<-

Offline mkawa

  •  No Marketplace Access
  • Thread Starter
  • Posts: 6562
  • (ツ)@@@. crankypants
Re: Bug Reports
« Reply #39 on: Sat, 11 August 2012, 12:16:29 »
i have, but don't even have time to set it up yet.

anyway, i'm rewriting the spy this weekend so that it works + it's useful

re: notifications. i have not heard other reports of notifications not working. please chime in if your notifications also don't work

to all the brilliant friends who have left us, and all the students who climb on their shoulders.

Offline sth

  • 2 girls 1 cuprubber
  • Posts: 3400
  • ftdoc.nl
    • forthedeclineofcivilisation
Re: Bug Reports
« Reply #40 on: Sat, 11 August 2012, 14:06:44 »
notifications work but i am unable to un-subscribe from some threads.
11:48 -!- SmallFry [~SmallFry@unaffiliated/smallfry] has quit [Ping timeout: 245 seconds] ... rest in peace

Offline mkawa

  •  No Marketplace Access
  • Thread Starter
  • Posts: 6562
  • (ツ)@@@. crankypants
Re: Bug Reports
« Reply #41 on: Tue, 14 August 2012, 07:47:08 »
i ended up finding some other cruft in the SMF distribution that i took care of this weekend that will fix the youtube GUI button.

i fixed the small spy issues for now (but not a full rewrite yet), and added locations to the left-side user info. we should be deploying these changes quite soon

to all the brilliant friends who have left us, and all the students who climb on their shoulders.

Offline mkawa

  •  No Marketplace Access
  • Thread Starter
  • Posts: 6562
  • (ツ)@@@. crankypants
Re: Bug Reports
« Reply #42 on: Tue, 14 August 2012, 09:11:17 »
silly bug with youtube button not showing in editor is now fixed

to all the brilliant friends who have left us, and all the students who climb on their shoulders.

Offline hazeluff

  • * Vendor
  • Posts: 2384
  • Location: Vancouver, BC
  • DEMILK!
    • Originative
Re: Bug Reports
« Reply #43 on: Tue, 14 August 2012, 09:17:15 »
Someone keeps messing with my head.
Show Image


This bug is really irking me right now. = (

Offline mkawa

  •  No Marketplace Access
  • Thread Starter
  • Posts: 6562
  • (ツ)@@@. crankypants
Re: Bug Reports
« Reply #44 on: Tue, 14 August 2012, 09:38:15 »
rknize hasn't written up the deployment instructions for me yet :X

to all the brilliant friends who have left us, and all the students who climb on their shoulders.

Offline hazeluff

  • * Vendor
  • Posts: 2384
  • Location: Vancouver, BC
  • DEMILK!
    • Originative
Re: Bug Reports
« Reply #45 on: Tue, 14 August 2012, 09:40:26 »
Also I have a bug called demik = / That bug is particularly bad.

Offline rknize

  • * Administrator
  • Posts: 1717
  • Location: Chicago
    • metaruss
Re: Bug Reports
« Reply #46 on: Tue, 14 August 2012, 10:55:47 »
Your changes are deployed, mkawa.
Russ

Offline mkawa

  •  No Marketplace Access
  • Thread Starter
  • Posts: 6562
  • (ツ)@@@. crankypants
Re: Bug Reports
« Reply #47 on: Tue, 14 August 2012, 11:22:25 »
Also I have a bug called demik = / That bug is particularly bad.
UNFIXABLE

to all the brilliant friends who have left us, and all the students who climb on their shoulders.

Offline bpiphany

  • Posts: 1012
  • Location: Stockholm, Sweden
  • bpiph is a special type of crazy. //mkawa
Re: Bug Reports
« Reply #48 on: Tue, 14 August 2012, 17:22:07 »
This may already have been addressed.. but getting into the full editor when editing an already posted post, is even less obvious than when creating a new post.

There are no "goto last post" links in the notifications view. They would be handy to me at least, since I keep that page as sort of a bookmarks page.

Offline mkawa

  •  No Marketplace Access
  • Thread Starter
  • Posts: 6562
  • (ツ)@@@. crankypants
Re: Bug Reports
« Reply #49 on: Tue, 14 August 2012, 18:22:56 »
when i hit modify i go immediately to the full editor. hmm.. did you turn the wsywig editor off in your options panel?

to all the brilliant friends who have left us, and all the students who climb on their shoulders.