Author Topic: RMA replacement QFR blue turns out to be complete dud  (Read 57621 times)

0 Members and 1 Guest are viewing this topic.

Offline mbamg

  • Thread Starter
  • Posts: 1
  • Location: Canada
RMA replacement QFR blue turns out to be complete dud
« on: Sat, 27 September 2014, 21:49:36 »
So I RMA'd my QuickFire Rapid since some of my keys weren't registering, then promptly received a replacement which appeared to be a newer version.

Turns out that replacement is even worse than the original - the computer can't even detect it. Thinking that it's a cable problem, I swapped USB cables, and tried different PS/2 adapters. Shut down the machine and restarted. Nothing. One time it even froze my bootup message screen. Grabbed other PS/2 and USB keyboards and tried them one by one. No problem recognizing, so it's not my motherboard's fault.

Then I tried the same procedure on other machines and OS's. Linux, Windows, Mac OS X, none of these would detect the board. I know power is being supplied to the board - the start button lock light always comes on when I perform that combo, but the device isn't even showing up under Device Manager.

I've filed a support ticket hoping they'll get me another replacement. This is getting ridiculous.