geekhack Community > Keyboards

Issues with a model F


Hello everyone, I've been a huge fan of everything buckling spring for a long time, but I recently decided to branch out from my usual model M's and try out an F. I bought one and a soarer's converter and plugged it in - instant success, plug and play and it worked fine...for 10 minutes. I left the room and by the time I got back, it stopped registering any keys. The converter is still being recognized and I tried HID listen, but I don't think it recognizes that anything is attached, this is what it gives me:


remaining: FFFC

Keyboard ID: 0000
Code Set: 1
Mode: PC/XT


Any help would be appreciated, I would love to get this one up and running as I find that I prefer the feeling of the switches over my model m! The only thing I can think of is maybe the cable has some damage, I did adjust it a small bit right when it was last working.

There is the standard advice to start over. Unplug and re-seat all the cables and connections. Possibly open the case and make certain the the interior connection is secure.

Are you using one of Orihalcon's converter cables on an F XT? He is a member here and might have a suggestion.

I was a bit light on the details for what I've tried so far in the initial post, but I've done most of the common troubleshooting stuff (checking connections, reseating the cable, reseating the ground, etc) to no avail. And yes, I did buy the converter from Orihalcon, hopefully he can give me a bit of help!


[0] Message Index

Go to full version