geekhack Community > Input Devices

Weird question: devices to 'pass through' USB keyboard?


This is a weird one: I'm trying to get an Apple A1243 to work with my linux desktop.

After much trial and error, it seems that there is a fundamental problem with the keyboard and the bootloader (grub). I'll spare you all the details, but suffice to say it's not the keyboard (tried a second copy), not the USB port, and nothing that can be solved by grub or BIOS configuration (as far as I have discovered). It fails to work in grub, but is otherwise (mostly) fine. Other keyboards work fine, including the Apple A1843; it's just the A1243 that doesn't work in grub.

This had me wondering about devices that may exist to go between the keyboard and grub that might fix the issue.

E.g. going keyboard -> USB-PS2 adapter -> PS2-USB adapter -> computer, or products like this "controller/converter", etc. Anything to come between grub and the keyboard to interrupt whatever the issue is. I've tried going through a USB hub but that didn't change anything.

Weird question, I know, but if you can think of any cheap little device that would effectively "shield" the computer in a way that might interrupt whatever the cause of the bug is, I'd be curious to know. I've not (yet) been able to find a keyboard I like better.


Weird. I can only speculate...

What kind of hardware are you using? A standard Intel/AMD PC, Intel Macintosh, ARM Mac or something else?

The A1243 has a built-in USB hub. This means that the keyboard device is actually connected through the hub.
Perhaps that is a problem for Grub, I wonder.

Have you disabled any feature in BIOS that would power the USB port (and thus, the keyboard) while the computer is "off"? Modern computers are really never truly off unless you disconnect its power source: otherwise they tend to power the USB ports unless that is disabled in BIOS.
There have been problems with USB peripherals retaining state from the previous session that don't get reset when the system reboots, because the BIOS does not properly reset the device over the USB protocol. A device should be reset if the power is dropped.
Have you tried disconnecting and reconnecting the keyboard before "starting up" the computer?
If that makes the keyboard work, then I would look again in the BIOS for a setting that would shut it off. Perhaps you would need to plug it into another USB port.

Appreciate the brainstorming!

Intel/AMD (Gigabyte ga-z87x-ud3h). I've tried numerous combinations of plugging/unplugging, different ports, etc, to no effect. I can't find any settings in the bios to truly shut off USB ports, but doesn't seem like it would help, given the results of unplugging/plugging?

Oddly enough, there were a few times it worked at the grub screen; If (and only if) I went from the keyboard -> USB extension cable -> USB port in the side of a monitor -- the bios boot screen worked with the keyboard in that case. But if I plugged keyboard -> extension cable -> [desktop, or USB port in the front of desktop], it wouldn't work until the OS is booted... and at any rate, it was only temporary: at this point it doesn't work at the grub screen in any of those configurations. (And the same is true for both of the A1243 keyboards I now have. so it doesn't appear to be an issue with a particular keyboard.)

Given the intermittent nature of it, I was left wondering if there was just some hardware issue with this model that fails over time, or some kind of bad shielding that let EMI cause problems, etc. Regardless, I can't find a configuration that works. Hence my speculation that some kind of trickery where I use an intermediate device to bridge between the keyboard and the computer might be possible.

Some exciting developments and further info:

- it works in BIOS, which I did not mention before, just not at the grub screen (I have to get into BIOS with a second keyboard, but the Apple keyboard works fine in the BIOS UI.)
- if I boot to grub, it does not work. However, if I REboot from grub back into grub again (ctrl-alt-del on a second keyboard) it DOES work in grub afterwards. I can reboot from grub over and over and the keyboard works in grub every time (!).
- however, if I boot from grub into linux or windows, and then reboot, it's back to not working in grub again
- when plugging in at boot it seems to start in the "not working" state

I don't know if any of this is actually useful for brainstorming clever solutions. :-) I'm investigating things like unassociating the USB device before restarting, etc. But if I can't find an alternative keyboard I prefer, I'm tempted to just get a second keypad with arrow keys and an enter key off to the side... it's just tantalizingly close to working... :-)


[0] Message Index

Go to full version