geekhack Community > Input Devices

ITAC mouse-trak PS/2 version - using on USB


Hi everybody,

I have aquired a model B-MPIND which is the Industrial type, PS/2, and dated 2002 inside. It has a completely different board to the 2007 USB version (thanks to user Tactile posting on another thread here to a link to a photo) so I guess it needs at least an active adapter to work on USB.

I've tried a random dual mouse & keyboard PS/2 to USB cable, no details whatsoever on it but it's active. It didn't work.

XibariS on r/Trackballs has ingeniously managed to convert a very similar 2005 Professional PS/2 mouse-trak (B-5XXMP A0002) by adding a converter board based on a CSC0101A "dual PS/2 to USB Data Converter Controller. I might be up for that, but the ebayer selling the board in Germany won't ship to the UK, I expect because of Brexit.

I'm resigned to using a cable adapter - anything to get the mouse-trak working! I am dimly aware that the board's controller is the basis of some of the external cables and is seen as good and it tends to work. Before I go buying a slew of cable adapters, I wonder if anyone here has any experience of using these PS/2 mouse-traks with USB and if so, any steer on cables (or boards to fit internally) would be really good to hear about.

Many thanks.

I tested these three converters:

The procedure was the same for all three:
Shut down computer
Plug trackball into converter
Plug converter into USB port
Turn computer on
The blue cube did not work. No surprise there since it's intended for keyboards only
Both of the other converters worked fine

These converters are at least ten years old and may not be available, or may have been revised.

Thanks very much for the full response. I did follow that procedure (strangely, more than once when it didn't work the first time). The trendnet (or a converter looking identical) is available from USA ebay but postage is a bit grim to the UK. The Ziotek cable one doesn't show up to buy anywhere. But you've taught me that at least a couple of cables do work with the Mouse-trak. Earlier today I identified that the StarTech converter uses the CSC0101A chip, so I ordered one, that might do the trick.

OK, it's working ;D. The StarTech adapter ("usbps2pc") with the Chesen CSC0101A-S16G chip set did it - plug and play on both Windows 10 & Linux Mint XFCE. I have no idea if the first adapter I had was unusual in not working with this trackball (it worked with a PS/2 mouse I have), or if this StarTech one is unusual in working with it. Maybe most adapters have this chipset and work because of it. I will be checking any more adapters I come across just for interest.


[0] Message Index

Go to full version