Author Topic: Non-working Key on a Model M  (Read 1199 times)

0 Members and 1 Guest are viewing this topic.

Offline BrooklynTony198

  • Thread Starter
  • Posts: 31
  • Location: Hawaii, USA
  • A person was here.... Now its only keyboards.
Non-working Key on a Model M
« on: Thu, 02 April 2020, 22:11:52 »
Hello fellow Model M owners! I'm currently restoring a 1987 silver label Model M, with part number 1390120. Boy so far this has been an interesting project. I had agreed to bolt mod it for a friend, and it arrived in terrible condition. It had stopped working entirely, and when I opened it up, not only was it filthy, but EVERY SINGLE PLASTIC RIVET had fallen out. I tried to bolt mod it, but the barrel plate cracked into pieces when I tried to rescrew it. One Unicomp order later, and now it has a brand new barrel plate, but it still is slightly broken.

The key issue here is that the "V" key has failed. I knew this was an issue from before, as the owner had said that the V key stopped working a long time before the rest of the keys. At first I thought this was due to the slowing breaking plastic rivets. But that isn't the reason it doesn't work, since it should now that I bolt modded it. The spring does buckle, the flipper does move, but the membrane doesn't seem to sense it. So I came to consult you guys on how I should move forward. What is the most likely issue? Should I get a new membrane assembly from Unicomp? Or is it a simple fix?
« Last Edit: Thu, 02 April 2020, 23:14:54 by BrooklynTony198 »
            
  IBM Model M5-2        IBM Model F XT       Asteria60             AntaresTKL           Scorpii9

Online yui

  • Posts: 727
  • Location: 127.0.0.1 (in azerty)
Re: Non-working Key on a Model M
« Reply #1 on: Fri, 03 April 2020, 03:27:45 »
i fixed a membrane with a multimeter in ohm mode and a bit of conductive tape, if it is a broken or oxidized trace, the problem with that is that it seems to only be V, for me a broken trace would kill a bunch of keys usually, the safest bet would be to buy from unicomp for sure, because if the membrane has started corroding it will continue and the board will break again.
there might be other problem that could cause that that i am not aware of.
vi vi vi - the roman number of the beast (Plan9 fortune)

Offline BrooklynTony198

  • Thread Starter
  • Posts: 31
  • Location: Hawaii, USA
  • A person was here.... Now its only keyboards.
Re: Non-working Key on a Model M
« Reply #2 on: Fri, 03 April 2020, 04:11:44 »
the safest bet would be to buy from unicomp for sure

I'm still very confused how to "input membrane part number" on their buy page.
            
  IBM Model M5-2        IBM Model F XT       Asteria60             AntaresTKL           Scorpii9

Online yui

  • Posts: 727
  • Location: 127.0.0.1 (in azerty)
Re: Non-working Key on a Model M
« Reply #3 on: Fri, 03 April 2020, 05:26:56 »
the safest bet would be to buy from unicomp for sure

I'm still very confused how to "input membrane part number" on their buy page.

there should be a number on each membrane and a membrane assembly number on both, if you have doubts you can contact them, they are very helpful, although with the current situation they may not be able to answer right now.
vi vi vi - the roman number of the beast (Plan9 fortune)

Offline BrooklynTony198

  • Thread Starter
  • Posts: 31
  • Location: Hawaii, USA
  • A person was here.... Now its only keyboards.
Re: Non-working Key on a Model M
« Reply #4 on: Fri, 03 April 2020, 15:35:02 »
f the membrane has started corroding it will continue and the board will break again.
there might be other problem that could cause that that i am not aware of.

I'm going to try and clean off the membrane. It looks fine, but it may be that I need to clean the trace. It looks like someone spilled water in this thing at some point, or it had been fixed before... The membrane connectors have a lot of wear. How should I clean the membrane?
            
  IBM Model M5-2        IBM Model F XT       Asteria60             AntaresTKL           Scorpii9

Offline fohat.digs

  • * Elevated Elder
  • Posts: 5991
  • Location: 3555'N, 8353'W
  • weird funny old guy
Re: Non-working Key on a Model M
« Reply #5 on: Fri, 03 April 2020, 15:56:37 »
How should I clean the membrane?

I would *gently* wipe it with a wet paper towel first to remove dirt. Maybe weak alcohol next, with wet paper towel afterwards to remove any residue.

If you have wear already, any abrasive cleaning will accelerate the erosion. Once the connection is gone, you will have to use something like paint or tape to replace it.

" When a man unprincipled in private life, desperate in his fortune, bold in his temper, despotic in his ordinary demeanour known to have scoffed in private at the principles of liberty when such a man is seen to mount the hobby horse of popularity to join in the cry of danger to liberty to take every opportunity of embarrassing the General Government & bringing it under suspicion to flatter and fall in with all the non sense of the zealots of the day It may justly be suspected that his object is to throw things into confusion that he may 'ride the storm and direct the whirlwind'. "
Alexander Hamilton 1792

Offline BrooklynTony198

  • Thread Starter
  • Posts: 31
  • Location: Hawaii, USA
  • A person was here.... Now its only keyboards.
Re: Non-working Key on a Model M
« Reply #6 on: Fri, 03 April 2020, 16:09:21 »
How should I clean the membrane?

I would *gently* wipe it with a wet paper towel first to remove dirt. Maybe weak alcohol next, with wet paper towel afterwards to remove any residue.

If you have wear already, any abrasive cleaning will accelerate the erosion. Once the connection is gone, you will have to use something like paint or tape to replace it.

Thanks, I will do that this weekend and see if it fixes the issue.
            
  IBM Model M5-2        IBM Model F XT       Asteria60             AntaresTKL           Scorpii9

Offline BrooklynTony198

  • Thread Starter
  • Posts: 31
  • Location: Hawaii, USA
  • A person was here.... Now its only keyboards.
Re: Non-working Key on a Model M
« Reply #7 on: Sat, 04 April 2020, 05:57:30 »
Just cleaned the membrane and the keyboard is fully up and running! Thanks for your help!
            
  IBM Model M5-2        IBM Model F XT       Asteria60             AntaresTKL           Scorpii9

Offline jacethesaltsculptor

  • Posts: 305
  • Location: Arizona - USA
  • IBM = I Buy Model-M's
Re: Non-working Key on a Model M
« Reply #8 on: Wed, 08 April 2020, 14:32:26 »
Happy to hear an old Silver Badge is up and running again.  :)

I didn't have anything to do with this, but thanks for replying and saying that you got it working, looking these sorts of threads up in the future is an invaluable resource for these sorts of issues.

Unicomp M122 - Unicomp Classic Trackball - IBM Model M13 - IBM Model F122 - IBM Model F Bigfoot - IBM Model F AT - Ducky Shine 3 Yellow

Offline Maledicted

  • Posts: 1542
  • Location: Wisconsin, United States
Re: Non-working Key on a Model M
« Reply #9 on: Wed, 08 April 2020, 16:02:24 »
Happy to hear an old Silver Badge is up and running again.  :)

I didn't have anything to do with this, but thanks for replying and saying that you got it working, looking these sorts of threads up in the future is an invaluable resource for these sorts of issues.

Agreed. The silver badge bricks deserve TLC, and I know that for years before joining Geekhack, I have used threads just like this to learn things and resolve problems. Some closure is always great, when possible.