Author Topic: Leopold FC660c connecting problem  (Read 840 times)

0 Members and 1 Guest are viewing this topic.

Offline Blehhh

  • Thread Starter
  • Posts: 15
Leopold FC660c connecting problem
« on: Mon, 22 June 2020, 01:34:52 »
Hi everyone, i have a Leopold FC660c, it seems each time i on a PC or restart i have to unplug and replug everytime, sometimes more than once or twice to get it working.
i tried not touching at all for a few minutes it doesnt work.
does anyone know the solution or fix to this?
would greatly appreciate this.
Thanks in advance and stay safe :)

Offline Maledicted

  • Posts: 1261
  • Location: Wisconsin, United States
Re: Leopold FC660c connecting problem
« Reply #1 on: Mon, 22 June 2020, 10:21:36 »
Did you try other USB ports? Did you try different USB cables? Do the contacts on either end of the cable, and the mini USB female socket look oxidized/dirty? Does anything look bent?

Offline Rob27shred

  • Posts: 1004
  • Location: Pittsburgh, PA
  • insane in the membrane
Re: Leopold FC660c connecting problem
« Reply #2 on: Mon, 22 June 2020, 11:10:04 »
Did you try other USB ports? Did you try different USB cables? Do the contacts on either end of the cable, and the mini USB female socket look oxidized/dirty? Does anything look bent?

All solid advice there, if it is a problem with the USB port on the KB itself Hasu makes aftermarket controllers for the 660C that is QMK compatible. Or if the Hasu 660C controller is not something that interests you, if you put a WTB post up I'm sure someone who has swapped controllers out in their 660C would be willing to sell the stock one.

Offline Tactile

  • Posts: 1285
  • Location: Portland, OR
Re: Leopold FC660c connecting problem
« Reply #3 on: Mon, 22 June 2020, 15:06:41 »
If you're running Windows, here's something to try:

In Device Manager, under "Universal Serial Bus controllers" go through the entire list and if they have a "Power Management" tab, ensure "Allow the computer to turn off this device..." is not checked.

245547-0