Author Topic: Keyboard PCB no longer recognized  (Read 508 times)

0 Members and 1 Guest are viewing this topic.

Offline rexteram

  • Thread Starter
  • Posts: 2
Keyboard PCB no longer recognized
« on: Sat, 17 October 2020, 14:53:16 »
Hello, before I get into anything I would like to say that it is a bit lengthy in explanation but that is only because I wish to make sure I cover everything. There will be a TLDR at the bottom if you do not wish to read everything that led to this point.

Ok, so I have recently ordered the parts for the Arisu Keyboard (an Alice like keyboard that can be found here ) and, though not without issues, had it working last night and was quite happy. Unfortunately, when I unplugged the micro usb it came off of the board. The issue with this is that the plate made the solder joints inaccessible and so I tried to just lay it on top of the board first to see if it worked at all like that. The board did work, and so I de-soldered all of my switches, re-soldered the micro usb and put everything back on to have it all working again. As a counter measure, I took a little piece of acrylic from the plate that shipped with my case cutout to sandwich the micro usb between the board and the pcb. This worked well for a bit, and the keyboard was once again working. I had decided that I wanted to change the layout of the board, so I figured I would flash a new profile really quick then go to sleep. I shorted the pins to put it into boot mode (space b did not work) and while I was doing that, the micro usb detatched itself from the pcb once again as I was plugging it in. This caused it to disconnect and reconnect a few times, then in the end stopped working. At this point, it was 330 am and I was at my wit's end. I decided that instead of de-soldering all of the switches again, I would just make a cutout in the case itself so I could re-solder the micro usb there again because doing all of that de-soldering was an absolute pain as I have shaky hands (took me 3 hours).
So now with a cutout in my case, I put the micro usb back on and of course, it does not work anymore. I made sure all of the pins were touching the pads, which they were, and even wiggled the thing around a bit to see if I could get any connection at all. I have even tried a few different micro usb, both connectors and cables, and nothing has worked thus far. The computer does not even recognize when I plug the keyboard into the computer anymore. I see that there are some pads on the right of the micro usb that maybe I could try soldering a cable directly to and lose the functionality of being able to disconnect the cable, but I am unsure if this would work. I don't wish to spend much more money on this so I am hoping that you all could help me out here as I have no clue what to do anymore. Here are some other pictures to provide more details. [size=78%]


TLDR: micro usb came off while I was flashing a new profile onto the board and now it wont connect to the computer anymore even when I re-solder it back on.

Offline suicidal_orange

  • * Global Moderator
  • Posts: 3934
  • Location: England
Re: Keyboard PCB no longer recognized
« Reply #1 on: Sat, 17 October 2020, 15:48:35 »
Hopefully you didn't get really unlucky and it's just got corrupted/incomplete firmware.  If so you just need to short the pins and flash the firmware and it will work again.

Sounds like the connector is still likely to be a problem though, and you're right that the pads are an option.  If there's space in the case you could remove the socket from the PCB and cover the pads with electrical tape then attach a breakout board wired to the backup pads upside down so the socket still lines up with the hole?  Your pics show up as no entry signs so not sure if that's an option...
120/100g linear Zealio R1  
GMK Hyperfuse
'Split everything' perfection  
MX Clear
SA Hack'd by Geeks     
EasyAVR mod

Offline rexteram

  • Thread Starter
  • Posts: 2
Re: Keyboard PCB no longer recognized
« Reply #2 on: Sat, 17 October 2020, 19:21:13 »
I am gonna give the breakout board a try since I cant even get the pcb to be recognized on qmk toolbox to try reflashing anything so thanks for the input