Author Topic: [HELP] Keyboard acts as if Ctrl+Alt are pressed...  (Read 473 times)

0 Members and 1 Guest are viewing this topic.

Offline fade

  • Thread Starter
  • Posts: 5
[HELP] Keyboard acts as if Ctrl+Alt are pressed...
« on: Sat, 17 October 2020, 16:17:13 »
Hey guys I wasn't really sure where to ask help for this but so often when I type, something happens and my keyboard goes into another mode/configuration where it types letters with accents or does certain things as if I am holding Ctrl + Alt. In order to disable it I have to spam press FN + Spacebar. I don't have any other languages installed/enabled. I can't figure out what is causing this, something toggles it on and it's driving me mad.

Any help would be greatly appreciated.
Discord: fade#0001

Offline suicidal_orange

  • * Global Moderator
  • Posts: 3893
  • Location: England
Re: [HELP] Keyboard acts as if Ctrl+Alt are pressed...
« Reply #1 on: Sat, 17 October 2020, 16:33:42 »
As it has an FN key I guess it's a custom board?  If so is the soldering good or was it your first build and a bit dodgy?  Is it in a metal case, any chance it's getting a static shock?
120/100g linear Zealio R1  
GMK Hyperfuse
'Split everything' perfection  
MX Clear
SA Hack'd by Geeks     
EasyAVR mod
MX Brown 30g, HHKBish
Vortex OEM PBT
for See how the other half lives challenge!

Offline fade

  • Thread Starter
  • Posts: 5
Re: [HELP] Keyboard acts as if Ctrl+Alt are pressed...
« Reply #2 on: Sat, 17 October 2020, 16:38:38 »
As it has an FN key I guess it's a custom board?  If so is the soldering good or was it your first build and a bit dodgy?  Is it in a metal case, any chance it's getting a static shock?
Yep it's a custom board. I ordered it off of kbdfans when I first got into all this and they built it for me before shipping it off. Soldering seemed fine on it when I checked, it has polycarbonate case.

I think it's something that toggles it on since I have to press FN + Spacebar to toggle it off. Perhaps something to with my VIA settings but I can't see anything weird there.
Discord: fade#0001

Offline suicidal_orange

  • * Global Moderator
  • Posts: 3893
  • Location: England
Re: [HELP] Keyboard acts as if Ctrl+Alt are pressed...
« Reply #3 on: Sun, 18 October 2020, 02:16:59 »
It doesn't sound like a useful feature so you would have had to set it up by mistake which surely would be hard (one extra key maybe, but not two) - can you share your VIA config?

See if you can get it to happen reliably while running Aqua Key Test, or run it when the paoblem happens.  You're looking for things like it only happening on keys near the mods or maybe keys in the same row or column.

What board is it?  You could try a different firmware to confirm that's the problem rather than something hardware.
120/100g linear Zealio R1  
GMK Hyperfuse
'Split everything' perfection  
MX Clear
SA Hack'd by Geeks     
EasyAVR mod
MX Brown 30g, HHKBish
Vortex OEM PBT
for See how the other half lives challenge!

Offline fade

  • Thread Starter
  • Posts: 5
Re: [HELP] Keyboard acts as if Ctrl+Alt are pressed...
« Reply #4 on: Mon, 19 October 2020, 19:27:45 »
It doesn't sound like a useful feature so you would have had to set it up by mistake which surely would be hard (one extra key maybe, but not two) - can you share your VIA config?

See if you can get it to happen reliably while running Aqua Key Test, or run it when the paoblem happens.  You're looking for things like it only happening on keys near the mods or maybe keys in the same row or column.

What board is it?  You could try a different firmware to confirm that's the problem rather than something hardware.

I will try that thanks.

I am using the Polaris.
Discord: fade#0001