Author Topic: PCB problem  (Read 83 times)

0 Members and 1 Guest are viewing this topic.

Offline Kokkonen

  • Thread Starter
  • Posts: 1
PCB problem
« on: Tue, 23 February 2021, 11:58:52 »
Hello,

I have tried to solve this problem with all the online material there is available but with zero results.

I have been typing with ymdk96 for about half a year now. Suddenly middle of typing it typed itself a set of keys that are in one row. I have on that row keys "enter" "," "0" "pgup" "*" and "right arrow". After my kb typed those keys it stuck'd on "right arrow" and keep'd typing that until I pushed "fn" which somehow seemed to release those keys and I could type all other keys again normally but these "enter , 0 pgup * rightarrow".

Everytime I unplug and plug the pcb back in it just types those keys again and stuck on the right arrow. Again pressing "fn" releases these keys and I can continue without "enter , 0 pgup * rightarrow". However the fn works with no problem and I can use different layers.

What I have tried so far:

1. Checked the pcb properly with good light and all but there's no a single loose pin or misconnection on the board. I have even scraped small solder residues that might possibly cause the problem.

2. Loose all the stabilizer screws

3. Flashed the firmware again with different settings.

0 results

What I'm going to do next is to test the pcb with a mentimeter if it's because of a diode or wiring.

I have started to think if the problem is the atmega32u4 chip because of the odd symptoms. Overheating or something. Do anyone have an idea or experienced same problems?

Here is the wiring with the keys that does not work:
* Screenshot 2021-02-23 at 19.42.52.png (301.63 kB. 2306x742 - viewed 6 times.)
« Last Edit: Tue, 23 February 2021, 12:03:21 by Kokkonen »