Author Topic: SixKeyBoard + Mac OSX problem  (Read 18412 times)

0 Members and 1 Guest are viewing this topic.

Offline whoismikesmith

  • Thread Starter
  • Posts: 0
  • Location: Los Angeles
SixKeyBoard + Mac OSX problem
« on: Tue, 14 June 2016, 15:35:29 »
Working with a dual boot system on a 2013 MacBook Pro, OSX 10.10.5 and Windows 7 on the same machine.

Just got a SixKeyBoard after seeing the Tested.com review. It works flawlessly in Windows, and it works almost-flawlessly in OSX until I unplug it and plug it back in. If that happens, I have to shutdown and reset the SMC (Command+Option+Shift+power button after shutdown) for the SixKeyBoard to function again.
I noticed when I unplug it, and plug it back in, the 6key is listed in the System Report under USB, so I know the computer see's it, but I get no response when pressing keys.
Unplugging and plugging in has no negative effects in Windows.

I can keep resetting the SMC for now but I'm curious if someone has a deeper understanding of this issue or a possible fix.

Offline brucemcbruce

  • Posts: 0
Re: SixKeyBoard + Mac OSX problem
« Reply #1 on: Wed, 13 July 2016, 19:39:06 »
Lucky I saw this post, because I assumed my new 6KB was broken!

I'm getting the same symptoms as you -
I plug it in and it works,
I unplug & put it in another USB port and it is recognised in system info, but doesn't respond to keypresses,
I reset the SMC and it works again.

I haven't done much testing yet, so I'm not sure what the minimal fix is (is it necessary to reset the SMC, or is there a quicker/easier option?). It is a bit frustrating though!

For reference this is a single-boot 2013 MBP, running OSX 10.9.5.