Author Topic: [Solved] Help debugging assembled CKRB / Corne  (Read 1079 times)

0 Members and 1 Guest are viewing this topic.

Offline Heliobb

  • Thread Starter
  • Posts: 94
[Solved] Help debugging assembled CKRB / Corne
« on: Sun, 06 January 2019, 14:54:36 »
Hello  ;)

I received two pair of assembled Corne keyboards designed by Foostan. I was not convinced about my ability to solder the SMD leds. I read that it was difficult on Helix and Corne so I let the seller build it for me... But there are many issues, especially on one pair or keybaord. I would like to fix it myself.

1. Leds

Left hand keyboard have only backlight LED on. The rest is off. On the other part 5 key LEDs are always turn off. I saw them working once while I was flashing but I don't understand why it is not working.



I did some rgb reset but it doesn't change the behavior : https://github.com/qmk/qmk_firmware/blob/2c0bc5ed6be737e98377fa2299102f6737bbea72/keyboards/crkbd/keymaps/default/keymap.c#L237-L243

2. Keys

I have three deads keys. They are not producing any signal. Diodes are ok I checked them with multimeter, polarity is good too, I compared with my other working Corne keyboard. Soldering seems ok on Pro Micro, keycaps, and diodes. What could I check to see that everything is ok? Pro Micro output for this column?



And Highdef photos






Suggestion
1. I have the feeling that Pro Micro are not properly flashed even if I can correctly change the mapping on both hands, it seems that for deeper mechanism flash is not done properly, or maybe the firmware doesn't reset few behaviors?
2. Soldering can also be an issue, I have a good Weller soldering station but no heat station, so I can fix basic soldering. I don't see any bad soldering on the none working switch part but maybe I'm wrong
3. Maybe the pro micro is partially dead?

I read QMK documentation all the afternoon but I doesn't feel enough confident to start puting the multimeter everywhere on the pcb. Feel free to speak to me like if I was a newb :)
I would love to speak japanese to get help from Japan Discord keyboard group but sadly I am not. :/

Thanks in advance

« Last Edit: Sat, 16 February 2019, 15:10:25 by Heliobb »
Novatouch TKL - Leopold FC660C - PBT my life.

Offline elfmimi

  • Posts: 2
  • Location: Japan
Re: Help debugging assembled CKRB / Corne
« Reply #1 on: Tue, 08 January 2019, 04:49:16 »
Hi! I'm from japanese discord server.

Here, see attachment, I've illustrated the connection order of the LED data I/O chain of Corne's PCB.

Now, you may easily notice that the LEDs in the latter part of the chain are not working.
The reason, the LED next to the last one lighting correctry is broken! and not passing data on to the rest of the chain propperly.

These LED components are EXTREMELY vulnerable to heat of soldering.
It could be deficient soldering causing the defect, but in many cases it really is the broken LED causing that.
What you can do is just replacing the broken LEDs with new ones.
« Last Edit: Tue, 08 January 2019, 04:57:36 by elfmimi »

Offline Heliobb

  • Thread Starter
  • Posts: 94
Re: Help debugging assembled CKRB / Corne
« Reply #2 on: Tue, 08 January 2019, 16:20:47 »
Oh. I am so happy to read your answer. I will definitely change the first led that it is not working and resoldered one and continue until it is fixed!

Do you have any idea for the thumb row on the right keyboard?
Novatouch TKL - Leopold FC660C - PBT my life.

Offline elfmimi

  • Posts: 2
  • Location: Japan
Re: Help debugging assembled CKRB / Corne
« Reply #3 on: Tue, 08 January 2019, 22:37:12 »
As for the thumb's row I cannot point out what's wrong just by information known so far.

There are several things you may try to hunt down the cause of malfunction.

1. Connet USB cable to the right side by itself and see if the keys respond. (note: layout of the keys also get reversed. that's OK.)
2.  Try making a contact between pins of promicro, cf. image, and check if that makes any response corresponding thumb's row.
     (using a cut-off piece of wire or a pair of conductive tweezers.)
3. If it's not responsive from bottom side try it from front side.
« Last Edit: Tue, 08 January 2019, 23:03:16 by elfmimi »

Offline Heliobb

  • Thread Starter
  • Posts: 94
Re: Help debugging assembled CKRB / Corne
« Reply #4 on: Thu, 07 February 2019, 14:43:49 »
Sorry late reply. I was busy. I have correct contact when touching pins from the ProMicro for the columns and row that doesn't work normaly, diodes are ok.  :confused:
Novatouch TKL - Leopold FC660C - PBT my life.

Offline Heliobb

  • Thread Starter
  • Posts: 94
Re: Help debugging assembled CKRB / Corne
« Reply #5 on: Thu, 07 February 2019, 15:36:53 »
Ok the PCB track seems to have a continuity issue...



I compared a working pcb VS the problematic pcb then I soldered a hardwire to let the row working...



It works if I do this  :(



I didn't look at leds but maybe the issue is similar...
Novatouch TKL - Leopold FC660C - PBT my life.

Offline Heliobb

  • Thread Starter
  • Posts: 94
Re: Help debugging assembled CKRB / Corne
« Reply #6 on: Wed, 13 February 2019, 15:50:25 »
Thank you so much elfmimi. I fixed one part of the keyboard tonight. All leds were ok. I tested them one by one using an arduino an a small program.



I had two bad solders that I resolder with solder past and iron.

Fully working board with a small wire to skip the broken PCB track...   :D



I have another board to fix now. :)
Novatouch TKL - Leopold FC660C - PBT my life.

Offline Heliobb

  • Thread Starter
  • Posts: 94
Re: Help debugging assembled CKRB / Corne
« Reply #7 on: Sat, 16 February 2019, 15:10:03 »
Everything is fixed! I have many cold joins or joins that lead to interference (wrong LEDs flashing, half of the LEDs no working). I simply redo the soldered joints.

Soldered joints need to look like this


(from Helix build guide

Here is the result





Novatouch TKL - Leopold FC660C - PBT my life.