Author Topic: [Help] weird error I can't find the solution to..  (Read 1356 times)

0 Members and 1 Guest are viewing this topic.

Offline wLufty

  • Thread Starter
  • Posts: 5
  • Location: Buenos Aires
[Help] weird error I can't find the solution to..
« on: Fri, 16 July 2021, 15:31:28 »
So this is a weird error I'm having, tried the usual stuff, but the error in itself is weird..

I've 2 keyboard, one out of nowhere started to malfunction (sometimes it repeats keypresses, other times it gets stuck and spams the key non-stop). I went and did the usual (re flash, check for dirt, changed cable), tested it on 2 laptops I've and it works like a charm on both.

I tested my 2nd keyboard on the pc I'm having issues with, and if I use the oem cable it works perfectly (I'm writing here with it and is now my main keyboard), but if I use other cables I've laying around it does the same error of the other keyboard.

So, its not the keyboards, not the cables (since they work perfectly on my laptops), it has to be the pc in itself or the drivers.. I tried to uninstall the usb drivers but the error persist, could this be and issue on the motherboard(??) also I'm in doubt since the 2nd keyboard with the oem cable works perfectly and has no issues..

Any ideas are more than welcomed.
« Last Edit: Fri, 16 July 2021, 15:33:42 by wLufty »

Offline Leslieann

  • * Elevated Elder
  • Posts: 4007
Re: [Help] weird error I can't find the solution to..
« Reply #1 on: Sat, 17 July 2021, 04:23:28 »
The other cables are garbage.
Just because it works with one board does not mean it's flowing enough power, just that it's flowing enough power for the one board which probably uses less.

It could also be a two-fold problem in that a capacitor on the board that has issues is failing, and it could since the cable was limiting it's power and over-working it.
Novelkeys NK65AE w/62g Zilents/39g springs
More
62g Zilents/lubed/Novelkeys 39g springs, HK Gaming Thick PBT caps, Netdot Gen10 magnetic cable, pic
| Filco MJ2 L.E. Vortex Case, Jailhouse Blues, heavily customized
More
Vortex case squared up/blasted finish removed/custom feet/paint/winkey blockoff plate, HID Liberator, stainless steel universal plate, 3d printed adapters, Type C, Netdot Gen10 magnetic cable, foam sound dampened, HK Gaming Thick PBT caps (o-ringed), Cherry Jailhouse Blues w/lubed/clipped Cherry light springs, 40g actuation
| GMMK TKL
More
w/ Kailh Purple Pros/lubed/Novelkeys 39g springs, HK Gaming Thick PBT caps, Netdot Gen10 Magnetic cable
| PF65 3d printed 65% w/LCD and hot swap
More
Box Jades, Interchangeable trim, mini lcd, QMK, underglow, HK Gaming Thick PBT caps, O-rings, Netdot Gen10 magnetic cable, in progress link
| Magicforce 68
More
MF68 pcb, Outemu Blues, in progress
| YMDK75 Jail Housed Gateron Blues
More
J-spacers, YMDK Thick PBT, O-rings, SIP sockets
| KBT Race S L.E.
More
Ergo Clears, custom WASD caps
| Das Pro
More
Costar model with browns
| GH60
More
Cherry Blacks, custom 3d printed case
| Logitech Illumininated | IBM Model M (x2)

Offline wLufty

  • Thread Starter
  • Posts: 5
  • Location: Buenos Aires
Re: [Help] weird error I can't find the solution to..
« Reply #2 on: Sat, 17 July 2021, 09:10:56 »
The other cables are garbage.
Just because it works with one board does not mean it's flowing enough power, just that it's flowing enough power for the one board which probably uses less.

It could also be a two-fold problem in that a capacitor on the board that has issues is failing, and it could since the cable was limiting it's power and over-working it.

That could be it, since the one that works is a 60% and the one failing is a 75 with more lights than vegas..
Do you think this is a mobo issue, or could it be the psu?

Offline Leslieann

  • * Elevated Elder
  • Posts: 4007
Re: [Help] weird error I can't find the solution to..
« Reply #3 on: Sat, 17 July 2021, 22:59:31 »
That could be it, since the one that works is a 60% and the one failing is a 75 with more lights than vegas..
Do you think this is a mobo issue, or could it be the psu?
Not the mobo, if there is a capacitor dying, odds are it's going to be in the in the keyboard.
LEDs use way more power than people realize, especially when you toss in 100 of them plus resistors, it can easily over power a usb 2.0 port.

But..
It also could be a psu issue, check in bios and see what your 5v voltages are, if too far below 5v or jumping it can be a sign of the psu failing or the mobo failing. Pray it's not the psu. If it is, it may have already started destroying everything in the system using 5v. SSD, mobo, usb drives, mice, anything using 5v. Granted they will keep working until they stop, but I went through this once and months later I was still having thumbsticks fail even after recycling the entire system. Bad power supplies are massive problems and why so many of us who build computers spend stupid amounts on them. I've seen them do thousands of dollars in damage.

In bios, it can be off a bit, between variances in output and just how the mobo reads them it probably won't read 5v but hopefully it will be between 4.85 and 5.15.v
Novelkeys NK65AE w/62g Zilents/39g springs
More
62g Zilents/lubed/Novelkeys 39g springs, HK Gaming Thick PBT caps, Netdot Gen10 magnetic cable, pic
| Filco MJ2 L.E. Vortex Case, Jailhouse Blues, heavily customized
More
Vortex case squared up/blasted finish removed/custom feet/paint/winkey blockoff plate, HID Liberator, stainless steel universal plate, 3d printed adapters, Type C, Netdot Gen10 magnetic cable, foam sound dampened, HK Gaming Thick PBT caps (o-ringed), Cherry Jailhouse Blues w/lubed/clipped Cherry light springs, 40g actuation
| GMMK TKL
More
w/ Kailh Purple Pros/lubed/Novelkeys 39g springs, HK Gaming Thick PBT caps, Netdot Gen10 Magnetic cable
| PF65 3d printed 65% w/LCD and hot swap
More
Box Jades, Interchangeable trim, mini lcd, QMK, underglow, HK Gaming Thick PBT caps, O-rings, Netdot Gen10 magnetic cable, in progress link
| Magicforce 68
More
MF68 pcb, Outemu Blues, in progress
| YMDK75 Jail Housed Gateron Blues
More
J-spacers, YMDK Thick PBT, O-rings, SIP sockets
| KBT Race S L.E.
More
Ergo Clears, custom WASD caps
| Das Pro
More
Costar model with browns
| GH60
More
Cherry Blacks, custom 3d printed case
| Logitech Illumininated | IBM Model M (x2)

Offline wLufty

  • Thread Starter
  • Posts: 5
  • Location: Buenos Aires
Re: [Help] weird error I can't find the solution to..
« Reply #4 on: Fri, 30 July 2021, 08:54:08 »
That could be it, since the one that works is a 60% and the one failing is a 75 with more lights than vegas..
Do you think this is a mobo issue, or could it be the psu?
Not the mobo, if there is a capacitor dying, odds are it's going to be in the in the keyboard.
LEDs use way more power than people realize, especially when you toss in 100 of them plus resistors, it can easily over power a usb 2.0 port.

But..
It also could be a psu issue, check in bios and see what your 5v voltages are, if too far below 5v or jumping it can be a sign of the psu failing or the mobo failing. Pray it's not the psu. If it is, it may have already started destroying everything in the system using 5v. SSD, mobo, usb drives, mice, anything using 5v. Granted they will keep working until they stop, but I went through this once and months later I was still having thumbsticks fail even after recycling the entire system. Bad power supplies are massive problems and why so many of us who build computers spend stupid amounts on them. I've seen them do thousands of dollars in damage.

In bios, it can be off a bit, between variances in output and just how the mobo reads them it probably won't read 5v but hopefully it will be between 4.85 and 5.15.v

I know psu can damage everything, thats why I went for a evga p2, checked bios and the 5v readings are stuck in 5v so I'm guessing its something on the motherboard (because the keyboard works fine on every other pc) Thanks alot for helping me troubleshoot it, I really appreciate it.