Author Topic: GH60 programming issues  (Read 982 times)

0 Members and 1 Guest are viewing this topic.

Offline FlavortownFieri

  • Thread Starter
  • Posts: 2
GH60 programming issues
« on: Wed, 21 February 2018, 23:56:55 »
I am currently in the works of programming my Satan GH60. This is my first build and i am very confused on how to flash a keyboard layout onto it. Immediately  after plugging it in, it showed up as ATm32U4DFU with no driver installed. I then used Zadig to load winusb onto it, however i am realizing now that i could have just use easyAVR to build it and load on the layout. I have tried to this now using easyAVR and installing by going in to "Build and Reprogram", then selecting upload using flip (which i have version 3.4.7 installed) and then pressing the button on the back of my keyboard and then lastly pressing run. When I do this I get a message saying it has failed, the prompt says "AtLibUsbDfu.dll not found". Hoping someone would know where i went wrong and could send me in the right direction. I thought it could be due to installing WinUSB first as now whenever I go into device manager and try to change it into the Flip usb drivers it says that windows believes it has the best drivers and won't let me switch it, perhaps that could be whats preventing easyAVR and flip from being able to install the layout?

Offline FlavortownFieri

  • Thread Starter
  • Posts: 2
Re: GH60 programming issues
« Reply #1 on: Thu, 22 February 2018, 08:19:10 »
Or maybe if anyone knows a way to wipe winUSB off the chip and just start from scratch?

Offline hasu

  • Posts: 2755
  • Location: Tokyo, Japan
  • @tmk
    • tmk keyboard firmware project
Re: GH60 programming issues
« Reply #2 on: Fri, 23 February 2018, 02:10:52 »
Doesn't Zadig exist exactly for that?

I don't have any experience of the tool though.



Sent from my WAS-LX2J using Tapatalk

TMK products:HHKB Alt  ⌨ConvertersAlps64FC660C AltFC980C Alt

Offline Seeeeebs

  • Posts: 1
Re: GH60 programming issues
« Reply #3 on: Sun, 11 March 2018, 04:07:59 »
I had similar issues with my GH60s. 
The whole driver part of the problem was driving me crazy.  What fixed it for me was simply a change of USB port (I unplugged my main board and plugged my GH60 board to that port).  And BLAM!
After that; the guide below is what I followed and it worked for me.
https://imgur.com/a/rfezG

Offline suicidal_orange

  • * Global Moderator
  • Posts: 3054
  • Location: England
Re: GH60 programming issues
« Reply #4 on: Sun, 11 March 2018, 04:28:09 »
Oh yes, Windows' stupidity of not noticing it's the same device just in a different port so you have to wait for drivers when you plug your mouse in the 'wrong' hole.

Makes a change for this to have an upside :))
                               
Ducky Zero, MX Reds    JD40, Jailhouse Blues           GH60
Soarer controller