Author Topic: [GB] HS60 PCB - Hotswap 60% with SMD RGB LED's  (Read 16799 times)

0 Members and 2 Guests are viewing this topic.

Offline Lisinge

  • Posts: 99
  • Location: Sweden
Re: [GB] HS60 PCB - Hotswap 60% with SMD RGB LED's
« Reply #150 on: Mon, 16 July 2018, 17:41:57 »
Anyone else not able to get a response from Mechboards about defective hs60s lately?

I've found most success on discord. Pm david, he's been responding to me, slow at times but still responding :)

Offline silversilver

  • Posts: 3
Re: [GB] HS60 PCB - Hotswap 60% with SMD RGB LED's
« Reply #151 on: Tue, 07 August 2018, 05:10:19 »
Hello, I accidentally broke my HS60 ANSI PCB! Can I have the wiring map? I need to jump some wires.

thanks!

Offline silversilver

  • Posts: 3
Re: [GB] HS60 PCB - Hotswap 60% with SMD RGB LED's
« Reply #152 on: Tue, 07 August 2018, 05:14:33 »
Hello, I accidentally broke my HS60 ANSI PCB! Can I have the wiring map? Need to jump some wires.

Offline Mechboards

  • * Vendor
  • Thread Starter
  • Posts: 196
  • Location: UK
  • Mechboards UK
    • Mechboards
Re: [GB] HS60 PCB - Hotswap 60% with SMD RGB LED's
« Reply #153 on: Tue, 07 August 2018, 06:41:41 »
Hello, I accidentally broke my HS60 ANSI PCB! Can I have the wiring map? Need to jump some wires.

PM us a picture :)

Offline nimblejacks

  • Posts: 25
Re: [GB] HS60 PCB - Hotswap 60% with SMD RGB LED's
« Reply #154 on: Mon, 13 August 2018, 07:52:48 »
Having several issues with the PCB and none of the fixes have solved the problems... sent a PM to you guys.

Offline Mechboards

  • * Vendor
  • Thread Starter
  • Posts: 196
  • Location: UK
  • Mechboards UK
    • Mechboards
Re: [GB] HS60 PCB - Hotswap 60% with SMD RGB LED's
« Reply #155 on: Mon, 13 August 2018, 08:55:56 »
Having several issues with the PCB and none of the fixes have solved the problems... sent a PM to you guys.
I've sent it to the designer - awaiting reply

Sent from my F5121 using Tapatalk


Offline nimblejacks

  • Posts: 25
Re: [GB] HS60 PCB - Hotswap 60% with SMD RGB LED's
« Reply #156 on: Fri, 17 August 2018, 12:27:36 »
Having several issues with the PCB and none of the fixes have solved the problems... sent a PM to you guys.
I've sent it to the designer - awaiting reply

Sent from my F5121 using Tapatalk

When can I expect a response? Is there another method I can use to contact them directly? Thank you.

Online audax989

  • Posts: 625
  • Location: Guam
  • NOM NOM NOM
Re: [GB] HS60 PCB - Hotswap 60% with SMD RGB LED's
« Reply #157 on: Fri, 17 August 2018, 19:07:46 »
will the hhkb ever see an official release? if anyone has one lying around I have the perfect board for it.  :D

Offline Lisinge

  • Posts: 99
  • Location: Sweden
Re: [GB] HS60 PCB - Hotswap 60% with SMD RGB LED's
« Reply #158 on: Fri, 17 August 2018, 20:30:12 »
will the hhkb ever see an official release? if anyone has one lying around I have the perfect board for it.  :D

HHKB pcb is planned for round 2

Offline umalip

  • Posts: 36
  • Location: Frisco, TX
Re: [GB] HS60 PCB - Hotswap 60% with SMD RGB LED's
« Reply #159 on: Mon, 20 August 2018, 14:39:31 »
Is anyone else having issues with keypresses not registering with this PCB?  everything tested fine at first, then sporadically, had issues with presses not registering, and the board being unresponsive.  Every hour or 2, i need to unplug my board, and re-plug to reset it.  Am i the only one with these type of issues?

Offline quint

  • Posts: 3
  • Location: Vienna
Re: [GB] HS60 PCB - Hotswap 60% with SMD RGB LED's
« Reply #160 on: Tue, 21 August 2018, 06:21:47 »
Same with mine. No problems at all when u switch off the leds.. Try that..

Offline Mechboards

  • * Vendor
  • Thread Starter
  • Posts: 196
  • Location: UK
  • Mechboards UK
    • Mechboards
Re: [GB] HS60 PCB - Hotswap 60% with SMD RGB LED's
« Reply #161 on: Tue, 21 August 2018, 09:15:42 »
Is anyone else having issues with keypresses not registering with this PCB?  everything tested fine at first, then sporadically, had issues with presses not registering, and the board being unresponsive.  Every hour or 2, i need to unplug my board, and re-plug to reset it.  Am i the only one with these type of issues?

Same with mine. No problems at all when u switch off the leds.. Try that..

There are updated .hex files on the QMK depository which should solve these issues that you're having. We had to soft limit the LED's so they don't draw too much power. Just reflash with the updated .hex files. This should fix it :)

Offline umalip

  • Posts: 36
  • Location: Frisco, TX
Re: [GB] HS60 PCB - Hotswap 60% with SMD RGB LED's
« Reply #162 on: Tue, 21 August 2018, 10:38:21 »
Thanks!  I'll try that tonight!

Offline quint

  • Posts: 3
  • Location: Vienna
Re: [GB] HS60 PCB - Hotswap 60% with SMD RGB LED's
« Reply #163 on: Wed, 22 August 2018, 06:48:54 »
Good to hear that! Will test  :thumb:

Offline umalip

  • Posts: 36
  • Location: Frisco, TX
Re: [GB] HS60 PCB - Hotswap 60% with SMD RGB LED's
« Reply #164 on: Wed, 22 August 2018, 10:13:57 »
Yeah, that did not work.  sorry, i'm a noob at programming KB so it could possibly be my fault, so here's the steps i did:

1) updated my QMK and msys2
2) copied the updated config.h file to my keyboard folder with my edits to layout
3) made a .hex file and uploaded that to the keyboard via the "Reset" (FN+rt bracket)
4) test out keyboard, and if i type too fast, certain key strokes do not register

Offline silversilver

  • Posts: 3
Re: [GB] HS60 PCB - Hotswap 60% with SMD RGB LED's
« Reply #165 on: Wed, 22 August 2018, 10:22:20 »
Hello, I accidentally broke my HS60 ANSI PCB! Can I have the wiring map? Need to jump some wires.

PM us a picture :)

Pmed a few days ago. Please check. Thanks.

Offline enrique.aliaga

  • Posts: 92
Re: [GB] HS60 PCB - Hotswap 60% with SMD RGB LED's
« Reply #166 on: Mon, 27 August 2018, 16:26:16 »
Picture of my very first build ever. HS60 PCB + Sentraq Champagne Gold Aluminum Plate + GMK Screw-In stabs + EnjoyPBT 9009 + Pok3r case.

Offline Keebmeupscotty

  • Posts: 25
Re: [GB] HS60 PCB - Hotswap 60% with SMD RGB LED's
« Reply #167 on: Fri, 31 August 2018, 09:36:56 »
Having the same issues as umalip and quint. I have reflashed with (I think) the most up to date version of the repo but am still having the issue.

To elaborate on it further, it doesn't seem to be all RGB modes that are causing problems. It is the default one (which I actually like the most) that does a slow rotating wave/windmill effect of changing colors. It seems that one and another that is similar are causing the missed keypresses, as I am able to use other rgb modes and turn off the leds all together and everything works fine. I have resorted to not using the leds at all, but would love to be able to turn them on without fearing my keypresses won't register and the board will randomly disconnect. Please advise if there is anything else I can do.

Offline umalip

  • Posts: 36
  • Location: Frisco, TX
Re: [GB] HS60 PCB - Hotswap 60% with SMD RGB LED's
« Reply #168 on: Wed, 05 September 2018, 08:14:25 »
Having the same issues as umalip and quint. I have reflashed with (I think) the most up to date version of the repo but am still having the issue.

To elaborate on it further, it doesn't seem to be all RGB modes that are causing problems. It is the default one (which I actually like the most) that does a slow rotating wave/windmill effect of changing colors. It seems that one and another that is similar are causing the missed keypresses, as I am able to use other rgb modes and turn off the leds all together and everything works fine. I have resorted to not using the leds at all, but would love to be able to turn them on without fearing my keypresses won't register and the board will randomly disconnect. Please advise if there is anything else I can do.

I have re-flashed my board multiple times with the new config files in the QMK folder and have tried turning off and on the NKRO, and i'm still having issues with the board not matching my typing speed.  I have to type around 50-60 wpm just so it can keep up with my keystrokes.

Offline Mechboards

  • * Vendor
  • Thread Starter
  • Posts: 196
  • Location: UK
  • Mechboards UK
    • Mechboards
Re: [GB] HS60 PCB - Hotswap 60% with SMD RGB LED's
« Reply #169 on: Wed, 05 September 2018, 08:44:20 »
Having the same issues as umalip and quint. I have reflashed with (I think) the most up to date version of the repo but am still having the issue.

To elaborate on it further, it doesn't seem to be all RGB modes that are causing problems. It is the default one (which I actually like the most) that does a slow rotating wave/windmill effect of changing colors. It seems that one and another that is similar are causing the missed keypresses, as I am able to use other rgb modes and turn off the leds all together and everything works fine. I have resorted to not using the leds at all, but would love to be able to turn them on without fearing my keypresses won't register and the board will randomly disconnect. Please advise if there is anything else I can do.

I have re-flashed my board multiple times with the new config files in the QMK folder and have tried turning off and on the NKRO, and i'm still having issues with the board not matching my typing speed.  I have to type around 50-60 wpm just so it can keep up with my keystrokes.

To both,

This is an issue with QMK and the controller which we can't fix I'm afraid. Try using less intense LED effects. This will be changed in V2.

Offline umalip

  • Posts: 36
  • Location: Frisco, TX
Re: [GB] HS60 PCB - Hotswap 60% with SMD RGB LED's
« Reply #170 on: Wed, 05 September 2018, 08:49:38 »
Having the same issues as umalip and quint. I have reflashed with (I think) the most up to date version of the repo but am still having the issue.

To elaborate on it further, it doesn't seem to be all RGB modes that are causing problems. It is the default one (which I actually like the most) that does a slow rotating wave/windmill effect of changing colors. It seems that one and another that is similar are causing the missed keypresses, as I am able to use other rgb modes and turn off the leds all together and everything works fine. I have resorted to not using the leds at all, but would love to be able to turn them on without fearing my keypresses won't register and the board will randomly disconnect. Please advise if there is anything else I can do.

I have re-flashed my board multiple times with the new config files in the QMK folder and have tried turning off and on the NKRO, and i'm still having issues with the board not matching my typing speed.  I have to type around 50-60 wpm just so it can keep up with my keystrokes.

To both,

This is an issue with QMK and the controller which we can't fix I'm afraid. Try using less intense LED effects. This will be changed in V2.

Can i get a replacement v2 board?  I can return this one i have currently.

Online voight-kampff

  • Posts: 74
Re: [GB] HS60 PCB - Hotswap 60% with SMD RGB LED's
« Reply #171 on: Mon, 10 September 2018, 12:27:53 »
will there be a round two for the GB or will be the late on stock? I remember reading this somewhere, that is is planned to stock the PCB?

Offline hokie_programmer

  • Posts: 7
Re: [GB] HS60 PCB - Hotswap 60% with SMD RGB LED's
« Reply #172 on: Sat, 13 October 2018, 21:16:03 »
Hey everyone, I just got a PCB from someone off r/mm. It is registering all the keys correctly, but I might have broke the LED functionality. I turned it on and was tweaking all the settings and it looked like all the lights just suddenly turned off. Maybe the speed was too fast? Anyways, I cannot turn the light back on now. Anyone here have this problem before?

Never mind. I just had to reset it. All is good now.
« Last Edit: Sat, 13 October 2018, 21:34:33 by hokie_programmer »

Offline TheDankMatter

  • Posts: 8
  • Location: EU
  • Ladies & Gentlemen, We Are Floating In Space.
Re: [GB] HS60 PCB - Hotswap 60% with SMD RGB LED's
« Reply #173 on: Sun, 14 October 2018, 07:36:06 »
Still waiting for HHKB layout to happen  :thumb:

Offline RETURNISO

  • Posts: 31
Re: [GB] HS60 PCB - Hotswap 60% with SMD RGB LED's
« Reply #174 on: Sun, 14 October 2018, 09:49:09 »
Are we gonna see a V2 ISO version soon?  :eek:

Offline Mechboards

  • * Vendor
  • Thread Starter
  • Posts: 196
  • Location: UK
  • Mechboards UK
    • Mechboards
Re: [GB] HS60 PCB - Hotswap 60% with SMD RGB LED's
« Reply #175 on: Sun, 14 October 2018, 10:06:38 »
Still waiting for HHKB layout to happen  :thumb:

There will be one available :)

Hey everyone, I just got a PCB from someone off r/mm. It is registering all the keys correctly, but I might have broke the LED functionality. I turned it on and was tweaking all the settings and it looked like all the lights just suddenly turned off. Maybe the speed was too fast? Anyways, I cannot turn the light back on now. Anyone here have this problem before?

Never mind. I just had to reset it. All is good now.


Glad you got it sorted! Ify ou do have any issues with flashing etc moving forward lower the brightness of the LED's a couple clicks. Should help.

Are we gonna see a V2 ISO version soon?  :eek:

See below :) Prototype being tested so we'll be going into production again soon.

205392-0

Offline RETURNISO

  • Posts: 31
Re: [GB] HS60 PCB - Hotswap 60% with SMD RGB LED's
« Reply #176 on: Sun, 14 October 2018, 12:47:23 »

Are we gonna see a V2 ISO version soon?  :eek:
See below :) Prototype being tested so we'll be going into production again soon.

(Attachment Link)

YESSS :thumb: what a beauty of a ISO RETURN(S)  :p
« Last Edit: Sun, 14 October 2018, 12:49:18 by RETURNISO »

Online towhatend

  • Posts: 4
Re: [GB] HS60 PCB - Hotswap 60% with SMD RGB LED's
« Reply #177 on: Wed, 17 October 2018, 13:49:17 »
Will there be a version with ISO and split shift?  :D

Offline Rumai

  • Posts: 6
Re: [GB] HS60 PCB - Hotswap 60% with SMD RGB LED's
« Reply #178 on: Wed, 17 October 2018, 19:40:33 »
In for HHKB.

Offline Mechboards

  • * Vendor
  • Thread Starter
  • Posts: 196
  • Location: UK
  • Mechboards UK
    • Mechboards
Re: [GB] HS60 PCB - Hotswap 60% with SMD RGB LED's
« Reply #179 on: Thu, 18 October 2018, 10:05:12 »
Will there be a version with ISO and split shift?  :D

The GK64 already exists for 60% with arrows so I don't think we'll do split right shift :/

In for HHKB.

205601-0

Offline RETURNISO

  • Posts: 31
Re: [GB] HS60 PCB - Hotswap 60% with SMD RGB LED's
« Reply #180 on: Thu, 18 October 2018, 12:07:13 »
Will there be a version with ISO and split shift?  :D

The GK64 already exists for 60% with arrows so I don't think we'll do split right shift :/

In for HHKB.

[ Attachment Invalid Or Does Not Exist ]

Damn will all new v2 PCBAs be black?  :eek: How long time are you thinking before we can hit the preorder button?  :cool: